Skip to main content
SiteIndex

4xx クライアントエラー

414 URI が長すぎます

URI がサーバーの許容する長さを超えています。

URLのHTTPステータスを確認

意味

クエリパラメーターに多くのデータを含めた場合などに発生します。

よくある原因

  • クエリのデータが多すぎる。
  • 転送ループがパラメーターを追加し続けている。

解決方法

  1. 適切な場合は大きなデータを POST 本文で送ってください。
  2. 転送でパラメーターが循環していないか確認してください。

レスポンス例

HTTP/1.1 414 URI が長すぎます
Content-Type: text/plain; charset=utf-8

よくある質問

意味: HTTP 414
414 URI が長すぎます: URI がサーバーの許容する長さを超えています。
よくある原因: 414
クエリのデータが多すぎる。 転送ループがパラメーターを追加し続けている。
解決方法: HTTP 414
適切な場合は大きなデータを POST 本文で送ってください。 転送でパラメーターが循環していないか確認してください。

関連コード

ツール